summaryrefslogtreecommitdiff
path: root/flora/services/dockerhub.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flora/services/dockerhub.nix')
-rw-r--r--flora/services/dockerhub.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/flora/services/dockerhub.nix b/flora/services/dockerhub.nix
new file mode 100644
index 0000000..c9b84b3
--- /dev/null
+++ b/flora/services/dockerhub.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+{
+ services.dockerRegistry = {
+ enable = true;
+ port = 6000;
+ enableRedisCache = false;
+ extraConfig = {
+ storage.maintenance.readonly.enabled = true;
+ };
+ };
+
+ services.nginx.virtualHosts."registry.stuebinm.eu" = {
+ locations."/" = {
+ proxyPass = "http://localhost:6000";
+ proxyWebsockets = true;
+ };
+ enableACME = true;
+ forceSSL = true;
+ };
+
+ services.nginx.clientMaxBodySize = "0";
+}