summaryrefslogtreecommitdiff
path: root/flora/services/akkoma.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flora/services/akkoma.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flora/services/akkoma.nix b/flora/services/akkoma.nix
index efc693e..98cfb7b 100644
--- a/flora/services/akkoma.nix
+++ b/flora/services/akkoma.nix
@@ -6,6 +6,7 @@ let
inherit system;
overlays = [ (self: super: rec {
beamPackages = super.beam.packagesWith super.erlang_nox;
+ elixir = beamPackages.elixir_1_13;
}) ];
};
staticDir = "/var/lib/akkoma/static";
@@ -31,6 +32,14 @@ in
("${inputs.nixpkgs-unstable}/nixos/modules/services/web-apps/akkoma.nix")
];
+ # the pleroma_ctl wrapper uses pkgs.elixir, which without this is not the same
+ # as akkoma's elixir
+ nixpkgs.overlays = [
+ (self: super: {
+ elixir = unstable.beamPackages.elixir_1_13;
+ })
+ ];
+
system.stateVersion = "22.11";
services.akkoma = {