summaryrefslogtreecommitdiff
path: root/flora/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flora/configuration.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flora/configuration.nix b/flora/configuration.nix
index 51fee59..07d1049 100644
--- a/flora/configuration.nix
+++ b/flora/configuration.nix
@@ -54,9 +54,11 @@
services.logrotate = {
enable = true;
- paths.nginx = {
- path = "/var/log/nginx";
- frequency = "weekly";
+ # the nginx module does stuff here, which apparently no one tells anyone about
+ settings.nginx = {
+ rotate = 2;
+ nocompress = true;
+ compress = false;
};
};
@@ -67,9 +69,7 @@
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system = {
- stateVersion = "20.09"; # Did you read the comment?
- };
+ system.stateVersion = "20.09"; # Did you read the comment?
}