diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -3,10 +3,10 @@ description = "testing nix flakes for server deployment"; inputs = { - nixpkgs.url = "github:NixOS/nixpkgs/release-22.05"; + nixpkgs.url = "github:NixOS/nixpkgs/release-22.11"; nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; - home-manager.url = "github:nix-community/home-manager/release-22.05"; + home-manager.url = "github:nix-community/home-manager/release-22.11"; home-manager.inputs.nixpkgs.follows = "nixpkgs"; peerix.url = "github:cid-chan/peerix"; peerix.inputs.nixpkgs.follows = "nixpkgs"; @@ -87,12 +87,12 @@ homeConfigurations = let home = root: inputs.home-manager.lib.homeManagerConfiguration rec { - system = "x86_64-linux"; - homeDirectory = "/home/stuebinm"; - username = "stuebinm"; - configuration.imports = [ root ]; - stateVersion = "21.03"; - extraSpecialArgs = { inherit inputs system; }; + pkgs = nixpkgs.legacyPackages.x86_64-linux; + modules = [ root ]; + extraSpecialArgs = { + inherit inputs; + system = "x86_64-linux"; + }; }; in { stuebinm = home ./home/home.nix; |