summaryrefslogtreecommitdiff
path: root/chaski/services/bahnhof-name.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--chaski/services/bahnhof-name.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/chaski/services/bahnhof-name.nix b/chaski/services/bahnhof-name.nix
new file mode 100644
index 0000000..e0e2988
--- /dev/null
+++ b/chaski/services/bahnhof-name.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+{
+ systemd.services.bahnhof-name = {
+ enable = true;
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig.Type = "simple";
+ path = [ pkgs.bahnhof-name ];
+ script = ''
+ bahnhofname
+ '';
+ };
+
+ services.nginx.virtualHosts."bahnhof.name" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".proxyPass = "http://localhost:2345";
+ };
+}