summaryrefslogtreecommitdiff
path: root/chaski/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'chaski/configuration.nix')
-rw-r--r--chaski/configuration.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/chaski/configuration.nix b/chaski/configuration.nix
new file mode 100644
index 0000000..fa51fdf
--- /dev/null
+++ b/chaski/configuration.nix
@@ -0,0 +1,48 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ./hardware-configuration.nix
+ # ./services/jitsi.nix
+ ./services/uplcg.nix
+ ./services/woitb.nix
+ ./services/geolocation.nix
+ ./services/gtfs.nix
+ ];
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+ services.nginx.appendHttpConfig = ''
+ access_log off;
+ add_header Permissions-Policy "interest-cohort=()";
+ '';
+
+ # Use the GRUB 2 boot loader.
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+
+ networking.hostName = "chaski"; # Define your hostname.
+
+ # The global useDHCP flag is deprecated, therefore explicitly set to false here.
+ # Per-interface useDHCP will be mandatory in the future, so this generated config
+ # replicates the default behaviour.
+ networking.useDHCP = false;
+ networking.interfaces.ens10.useDHCP = true;
+ networking.interfaces.ens3.useDHCP = true;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "20.09"; # Did you read the comment?
+
+ boot.loader.grub.devices = [ "/dev/sda" ];
+
+}