summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2024-03-27 23:52:39 +0100
committerstuebinm2024-03-27 23:52:39 +0100
commitcea96f49fa71e9eaced1fe59fe8c9ab5392c2f6d (patch)
tree9e8fc8e781145385aaccee2303dbf304c55b31fd /pkgs/overlay.nix
parent9515be799112b405ff293d83705528b1e9237aa3 (diff)
help i wrote a matrix bot
not sure if this is a good idea or not, but i always liked how the IRC #voc-wok channel of the c3voc works, and I don't run my own IRC (nor do i want to have my monitoring on infra that is not my own), so I built a similar thing with matrix.
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 0194a2a..9d8b7b8 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -107,6 +107,15 @@ in
isabelle-rust-utils = self.isabelle-utils;
};
+ ntfy-matrix-bot = rustPlatform.buildRustPackage rec {
+ pname = "ntfy-matrix-bot";
+ version = "0.10";
+ src = inputs.ntfy-matrix-bot;
+ cargoLock.lockFile = "${src}/Cargo.lock";
+ doCheck = false;
+ meta.mainProgram = "ntfy-matrix-bot";
+ };
+
bahnhof-name =
let
haskellPkgs = self.haskellPackages.override (old: {