summaryrefslogtreecommitdiff
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorstuebinm2023-10-12 01:02:42 +0200
committerstuebinm2023-10-12 01:02:42 +0200
commit1795ddbbe908360d051289e450eb2cf054b44dfc (patch)
tree3e4fbc8ebf8dfbce57d7ae6db6e424c307103529 /pkgs/overlay.nix
parent0bc531e9d6aa27d32210917a82263cc676d8ab41 (diff)
playing around with radicle.xyz
this packages the heartwood cli tools, the radicle web interface, and runs a small example deployment on chaski. TODO: decide if i want to keep this thing, then add declarative config of the web interface, `rad auth`, and the radicle node to a NixOS module; the current state is kinda suboptimal to deploy.
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
index 7dc036e..59905f9 100644
--- a/pkgs/overlay.nix
+++ b/pkgs/overlay.nix
@@ -9,6 +9,7 @@ let
cargo = self.rust-bin.stable.latest.minimal;
rustc = self.rust-bin.stable.latest.minimal;
};
+ radicle = import ./radicle.nix;
in
{
galmon-core = self.callPackage (import ./galmon.nix {}) {};
@@ -70,9 +71,7 @@ in
version = "git";
src = inputs.isabelle-utils;
cargoLock.lockFile = "${src}/Cargo.lock";
- checkPhase = "
- echo skipping tests
- ";
+ doCheck = false;
};
isabat = import "${inputs.isabelle-utils}/isabat.nix" {
@@ -114,4 +113,8 @@ in
[ "PREFIX=$(out)" "WITH_POSIX_C_SOURCE=YES"
"WITH_GAMMACONTROL=YES" "WITH_LAYERSHELL=YES" "WITH_SCREENCOPY=YES" ];
})).override { wlroots = unstable.wlroots_0_16; stdenv = self.clangStdenv; };
+
+ heartwood = self.callPackage radicle.heartwood { inherit (rustPlatform) buildRustPackage; };
+
+ radicle-interface = self.callPackage radicle.interface {};
}