summaryrefslogtreecommitdiff
path: root/ilex/uffd.nix
diff options
context:
space:
mode:
authorstuebinm2023-01-27 20:37:46 +0100
committerstuebinm2023-01-27 20:37:46 +0100
commit69247cdf75796c69372a17d09beb1466315b1839 (patch)
tree7068b3d9ce9b3e4f7ced1d0614505f66f961d09e /ilex/uffd.nix
parente3a7cbc9bf986d0f27b4808b12899548a4a552c3 (diff)
working uffd on ilex for testing oauth2uffd-on-ilex
(just keeping this in a seperate branch in case i ever need it again)
Diffstat (limited to 'ilex/uffd.nix')
-rw-r--r--ilex/uffd.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/ilex/uffd.nix b/ilex/uffd.nix
new file mode 100644
index 0000000..a616b64
--- /dev/null
+++ b/ilex/uffd.nix
@@ -0,0 +1,34 @@
+{ stdenv, lib, python3Packages, fetchzip }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "uffd";
+ version = "2.0.1";
+
+ src = fetchzip {
+ url = "https://git.cccv.de/uffd/uffd/-/archive/v${version}/uffd-v${version}.tar.gz";
+ hash = "sha256-KP4J1bw5u7MklaPu2SBFRNyGgkKOBOpft5MMH+em5M4=";
+ };
+
+ patches = [ ./fix-setuppy.patch ]; # ./fix-userinfo.patch ];
+
+ propagatedBuildInputs = with python3Packages; [
+ flask
+ flask_sqlalchemy
+ flask_migrate
+ qrcode
+ fido2
+ oauthlib
+ flask-babel
+ argon2_cffi
+ itsdangerous
+ alembic
+ Mako
+ ];
+
+ postPatch = ''
+ sed -i -e 's/==[0-9.]\+//g' setup.py
+ '';
+
+ doCheck = false;
+ doInstallCheck = false;
+}