summaryrefslogtreecommitdiff
path: root/ilex/uffd-service.nix
diff options
context:
space:
mode:
authorstuebinm2023-01-27 20:37:46 +0100
committerstuebinm2023-01-27 20:37:46 +0100
commit69247cdf75796c69372a17d09beb1466315b1839 (patch)
tree7068b3d9ce9b3e4f7ced1d0614505f66f961d09e /ilex/uffd-service.nix
parente3a7cbc9bf986d0f27b4808b12899548a4a552c3 (diff)
working uffd on ilex for testing oauth2uffd-on-ilex
(just keeping this in a seperate branch in case i ever need it again)
Diffstat (limited to 'ilex/uffd-service.nix')
-rw-r--r--ilex/uffd-service.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/ilex/uffd-service.nix b/ilex/uffd-service.nix
new file mode 100644
index 0000000..000220f
--- /dev/null
+++ b/ilex/uffd-service.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+
+let
+ uffd = pkgs.callPackage ./uffd.nix {};
+in
+{
+
+ services.uwsgi = {
+ enable = true;
+ plugins = [ "python3" ];
+ instance = {
+ type = "normal";
+ pythonPackages = self: with self; [ uffd ];
+ module = "uffd:create_app()";
+ # socket = "${config.services.uwsgi.runDir}/uwsgi.sock";
+ http = ":8080";
+ env = [
+ "CONFIG_PATH=/tmp/uffd.conf"
+ "FLASK_ENV=development"
+ ];
+ hook-pre-app = "exec:FLASK_APP=${uffd}/lib/python3.10/site-packages/uffd flask db upgrade";
+ };
+ };
+}