summaryrefslogtreecommitdiff
path: root/hosts/flora/services/hedgedoc.nix
diff options
context:
space:
mode:
authorstuebinm2021-06-23 23:14:56 +0200
committerstuebinm2021-06-24 02:15:41 +0200
commite5f476b8088aeb399f9a89ec63882dd92754ee9a (patch)
tree26e0e995f3583090ef61cf63b8b6b7cbc81fe896 /hosts/flora/services/hedgedoc.nix
parent3c2f588cd95593bdbf7743a3f58321ddbac17038 (diff)
nixpkgs 20.09 → nixpkgs 21.05
Since pleroma is in nixpkgs 21.05, this requires some reshuffling to keep the unstable version of pleroma (otherwise the database versions are not compatible, and pleroma does not like database downgrades). Additionally, hedgedoc's database has been moved to a postgres user who is actually called hedgedoc.
Diffstat (limited to '')
-rw-r--r--hosts/flora/services/hedgedoc.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/hosts/flora/services/hedgedoc.nix b/hosts/flora/services/hedgedoc.nix
index 84721ce..038f99f 100644
--- a/hosts/flora/services/hedgedoc.nix
+++ b/hosts/flora/services/hedgedoc.nix
@@ -20,7 +20,7 @@ in
config = {config, pkgs, ... }: {
# open CodiMD port
- networking.firewall.allowedTCPPorts = [ config.services.codimd.configuration.port ];
+ networking.firewall.allowedTCPPorts = [ config.services.hedgedoc.configuration.port ];
# database (postgres 11), with default database reachable for CodiMD; no imperative config needed!
services.postgresql = {
@@ -28,7 +28,7 @@ in
package = pkgs.postgresql_11;
ensureDatabases = [ "codimd" ];
ensureUsers = [ {
- name = "codimd";
+ name = "hedgedoc";
ensurePermissions = { "DATABASE codimd" = "ALL PRIVILEGES";};
} ];
# ugly workaround to allow CodiMD to login without password — this service has lots of options,
@@ -36,6 +36,7 @@ in
authentication = pkgs.lib.mkForce ''
# Generated file; do not edit!
local all all trust
+ host codimd hedgedoc ::1/18 trust
host codimd codimd ::1/128 trust
'';
};