summaryrefslogtreecommitdiff
path: root/hosts/cyberbox/hardware-configuration.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-10 02:07:49 +0100
committerstuebinm2022-01-10 02:07:49 +0100
commitc48f90064724ce1d802038524f60cce7baf53e69 (patch)
tree8a601ab5527a3fdcf54d90d185e6cb056e30bae1 /hosts/cyberbox/hardware-configuration.nix
parent38ba8be512b8dbb8838fbca9865b2a8d24f6bee1 (diff)
add cyberbox (desktop config)
Diffstat (limited to '')
-rw-r--r--hosts/cyberbox/hardware-configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/hosts/cyberbox/hardware-configuration.nix b/hosts/cyberbox/hardware-configuration.nix
new file mode 100644
index 0000000..a724f02
--- /dev/null
+++ b/hosts/cyberbox/hardware-configuration.nix
@@ -0,0 +1,31 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usb_storage" "sd_mod" "sr_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/70a8042c-c5b5-4faa-8019-0eb042fbdf00";
+ fsType = "ext4";
+ };
+
+ boot.initrd.luks.devices."cryptroot".device = "/dev/disk/by-uuid/e53c9b77-5e00-40a0-bbda-62978b7b3000";
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/60cda588-b262-4394-8d38-284109a08a59";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}