summaryrefslogtreecommitdiff
path: root/hosts/chaski/services/woitb.nix
diff options
context:
space:
mode:
authorstuebinm2021-10-17 02:17:46 +0200
committerstuebinm2021-10-17 02:17:46 +0200
commit48724397491b978aeb061f0a9f0d0b65cb341418 (patch)
tree6e895152dfe61294f800bdb704f8d96196ed1b7b /hosts/chaski/services/woitb.nix
parentcbe5666097a0bf018eac0cf48ae6914db3bfe483 (diff)
add ilztal.live
Diffstat (limited to '')
-rw-r--r--hosts/chaski/services/woitb.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/chaski/services/woitb.nix b/hosts/chaski/services/woitb.nix
new file mode 100644
index 0000000..303ec0f
--- /dev/null
+++ b/hosts/chaski/services/woitb.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, ... }:
+
+let
+ #sources = ../../nix/sources.nix;
+ sources = /home/stuebinm/Dokumente/utils/playground/ilztal/server;
+in
+{
+ systemd.services.woitb = {
+ enable = true;
+ description = "wo ist die ilztalbahn?";
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig.type = "simple";
+ script = "${import sources}/bin/woitb";
+ };
+
+ services.nginx.virtualHosts."ilztal.live" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".root = pkgs.copyPathToStore
+ /home/stuebinm/Dokumente/utils/playground/ilztal/site;
+
+ locations."/upnext".proxyPass = "http://localhost:8000";
+ locations."/geoloc".proxyPass = "http://localhost:8000";
+ };
+
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+
+ services.nginx.appendHttpConfig = ''
+ access_log off;
+ add_header Permissions-Policy "interest-cohort=()";
+ '';
+}