summaryrefslogtreecommitdiff
path: root/hosts/chaski/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2021-03-19 23:08:35 +0100
committerstuebinm2021-03-19 23:08:35 +0100
commit4724971ef468ad792f56527f6b7ce570bf62601e (patch)
tree52395c0f5d322e609dde28b6f3f659ba1e764307 /hosts/chaski/configuration.nix
parentdeba8c91eb4892c31864c7d03506eb70cae1baff (diff)
simplify and deduplicate chaski config
Diffstat (limited to '')
-rw-r--r--hosts/chaski/configuration.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/hosts/chaski/configuration.nix b/hosts/chaski/configuration.nix
index 6aa24bc..14b297b 100644
--- a/hosts/chaski/configuration.nix
+++ b/hosts/chaski/configuration.nix
@@ -22,9 +22,6 @@
networking.hostName = "chaski"; # Define your hostname.
- # Set your time zone.
- time.timeZone = "Europe/Amsterdam";
-
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
# Per-interface useDHCP will be mandatory in the future, so this generated config
# replicates the default behaviour.
@@ -32,10 +29,6 @@
networking.interfaces.ens10.useDHCP = true;
networking.interfaces.ens3.useDHCP = true;
- environment.systemPackages = with pkgs; [
- wget curl htop iftop vim git
- ];
-
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. It‘s perfectly fine and recommended to leave
@@ -45,37 +38,5 @@
system.stateVersion = "20.09"; # Did you read the comment?
boot.loader.grub.devices = [ "/dev/sda" ];
- # Initial empty root password for easy login:
- users.users.root.initialHashedPassword = "";
- services.openssh.permitRootLogin = "prohibit-password";
- services.openssh.enable = true;
- # Replace this by your SSH pubkey
- users.users.root.openssh.authorizedKeys.keys = [
- "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQCTeuG1alKNNqoT2d5nUAlH0Otsk0NHM7nmkYC5Yfk8qcLsgY4v2dXlyrMzieajYgDjndEApgO3/S/V0EQGhvHc0UugC6LU84jHPwsgYVABRmFS74v/ww8NigaNIAevwWl+DxlnK4nnWdB1lo4xS69ooQdvoAjbubk16dP04LsAbH8Z+3cPB5WKAaayNx62DUwObzDSpztqCagCZzlqpwKG1UGJngrqEhk7B5Q0v9iCk91gqVkLSPllsB00+bqIimgkMVIZnoLLh7pcEgOvbG0yP2EG3ttDNN3jPpqE6mu+znfLq+ua/MwJy5hjmY5R54yPlcvFdsIU34jrdMCDvWqpV49VrLwVvkFN3lRZln/9eifkXXJciP4Ber3xEl8JltysV1PE5iJunWfbcOy0fwsYvBChDeyR5G3CLG2c25jKL9f1Iq95QBBMVYgIxq/dpGy0tjB+24w1JzsorvElsmz5etXLXCydLP07ic9PfSu1Wmwu7F0tweIk52x97sra6ePhtY+TTRffjjDz0DEho1bWDfrPV0xfPPAWXWTKYisVO4VVmMQsJbtXrfxUJbappM5vIXcJ+2JpT2Oh7Kiy3rjm+pd7rukgoCp7yN5z8v+2vuOfHqBuKUwlaRg/XNMyPrbnGGzVR1xzUuhwdOnjAyMmAr95Ne9hRBPwfVo2NR/ZZw=="
- ];
-
- users.users.git = {
- openssh.authorizedKeys.keys = config.users.users.root.openssh.authorizedKeys.keys;
- home = "/var/git";
- isNormalUser = true;
- };
-
- security.sudo.enable = false;
- security.acme = {
- acceptTerms = true;
- email = "stuebinm@disroot.org";
- };
-
-
- services.nginx = {
- enable = true;
- virtualHosts."stuebinm.eu" = {
- forceSSL = true;
- enableACME = true;
- };
- };
-
- networking.firewall.allowedTCPPorts = [ 80 442 ];
}
-