summaryrefslogtreecommitdiff
path: root/hosts/abbenay/configuration.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-18 09:43:24 +0100
committerstuebinm2022-01-20 13:19:44 +0100
commit0bcabe1c4b1dd74af233674dfa6c6ec3011ce2c0 (patch)
tree5c58943f99245ff7f745f50b46c34ae288c3e503 /hosts/abbenay/configuration.nix
parentdb83a406bc6e63289e47ff5d2228c08430832655 (diff)
restructuring directories
Diffstat (limited to 'hosts/abbenay/configuration.nix')
-rw-r--r--hosts/abbenay/configuration.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/hosts/abbenay/configuration.nix b/hosts/abbenay/configuration.nix
deleted file mode 100644
index 2aabaa7..0000000
--- a/hosts/abbenay/configuration.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- imports = [
- ./hardware-configuration.nix
- ];
-
- services.flatpak.enable = true;
- services.avahi.enable = true;
- services.avahi.nssmdns = true;
-
- services.xserver = {
- displayManager.gdm.enable = true;
- desktopManager.gnome.enable = true;
- };
- services.gnome.gnome-keyring.enable = pkgs.lib.mkForce false;
-
- environment.systemPackages = with pkgs; [
- gnome3.gnome-tweaks
- flatpak flatpak-builder
- # for mounting samba
- cifs-utils
- ];
-
- networking = {
- hostName = "matthias-nix";
-
- useDHCP = false;
- interfaces.enp3s0.useDHCP = true;
- # networkmanager shouldn't handle nixos container
- networkmanager.unmanaged = [ "interface-name:ve-*" ];
- };
- # nixos containers should have internet access
- networking.nat = {
- enable = true;
- internalInterfaces = ["ve-+"];
- externalInterface = "eth0";
- };
-
- boot = {
- extraModulePackages = with config.boot.kernelPackages; [ v4l2loopback ];
- kernelModules = [ "v4l2loopback" ];
- };
-
- # Use the systemd-boot EFI boot loader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
- boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
-
- # This value determines the NixOS release from which the default
- # settings for stateful data, like file locations and database versions
- # on your system were taken. It‘s perfectly fine and recommended to leave
- # this value at the release version of the first install of this system.
- # Before changing this value read the documentation for this option
- # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system.stateVersion = "20.03"; # Did you read the comment?
-
-}