summaryrefslogtreecommitdiff
path: root/flora/services/mail.nix
diff options
context:
space:
mode:
authorstuebinm2023-04-11 18:37:20 +0200
committerstuebinm2023-04-11 18:41:13 +0200
commit48d3f66855fb57379351fb9a458a95cf28522916 (patch)
tree730f4f9186a5a7f52e64236417ec384968eb96fd /flora/services/mail.nix
parent4e4eaf4838bbd45393d7a19ad182c8d4c076b043 (diff)
manage secrets with sops
not sure if i like this yet, but it seems worth trying it out.
Diffstat (limited to '')
-rw-r--r--flora/services/mail.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flora/services/mail.nix b/flora/services/mail.nix
index d41f0e8..e43e56f 100644
--- a/flora/services/mail.nix
+++ b/flora/services/mail.nix
@@ -3,7 +3,7 @@
{
imports = [ inputs.simple-nixos-mailserver.nixosModule ];
-
+ sops.secrets."mail/hashedPassword" = {};
mailserver = {
enable = true;
@@ -14,7 +14,7 @@
# nix run nixpkgs.apacheHttpd -c htpasswd -nbB "" "super secret password" | cut -d: -f2
loginAccounts = {
"hello@stuebinm.eu" = {
- hashedPasswordFile = "/var/mailstate/hello-password";
+ hashedPasswordFile = "/run/secrets/mail/hashedPassword";
aliases = ["postmaster@stuebinm.eu" "abuse@stuebinm.eu"];
};
};