summaryrefslogtreecommitdiff
path: root/flora/services/cgit.nix
diff options
context:
space:
mode:
authorstuebinm2022-09-14 15:12:15 +0200
committerstuebinm2022-09-14 15:15:42 +0200
commitb4651ea5cca0466525a5b33dccd934c946a98837 (patch)
tree69bba12beeabdf421880088ecf7542212e0ad297 /flora/services/cgit.nix
parenta8b3203e40fe3b9380a60ce9b8ff8ec2b8a92dc7 (diff)
cgit hopefully change default branch
kinda annoying that i don't get idle-indicators for repos that don't have a master-branch. not sure if this'll fix it though, cgit is weird.
Diffstat (limited to 'flora/services/cgit.nix')
-rw-r--r--flora/services/cgit.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flora/services/cgit.nix b/flora/services/cgit.nix
index e72f276..f5ef52a 100644
--- a/flora/services/cgit.nix
+++ b/flora/services/cgit.nix
@@ -47,12 +47,17 @@ let
cache-scanrc-ttl=1
+ defbranch=main
scan-path=/var/git/public
section=Forks
clone-url=https://stuebinm.eu/git/forks/$CGIT_REPO_URL
scan-path=/var/git/forks
'';
+
+ cgit = pkgs.cgit.overrideAttrs (old: {
+ patches = [./0001-main-instead-of-master-branch.patch];
+ });
in
{
services.fcgiwrap = {
@@ -68,7 +73,7 @@ in
locations."~ /git(/.*)".extraConfig = ''
fastcgi_pass unix:${config.services.fcgiwrap.socketAddress};
include ${pkgs.nginx}/conf/fastcgi_params;
- fastcgi_param SCRIPT_FILENAME ${pkgs.cgit}/cgit/cgit.cgi;
+ fastcgi_param SCRIPT_FILENAME ${cgit}/cgit/cgit.cgi;
fastcgi_param CGIT_CONFIG ${pkgs.writeText "cgit.conf" cgitconf};
fastcgi_param PATH_INFO $1;
'';