diff options
author | stuebinm | 2022-02-05 01:21:32 +0100 |
---|---|---|
committer | stuebinm | 2022-02-05 01:21:32 +0100 |
commit | e6718bd6298af2f6d540d97ab184fab5ab4d164b (patch) | |
tree | fc56c49ddc55d06a3e85e432643fd9db10ec0cb2 /flake.nix | |
parent | f486a1f424d49ff0ecc73e94cd2f17146a555cd9 (diff) |
add minimal home manager config
(mostly to reduce hassle / build times for smaller machines)
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 22 |
1 files changed, 14 insertions, 8 deletions
@@ -65,15 +65,21 @@ checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib; - homeConfigurations.stuebinm = inputs.home-manager.lib.homeManagerConfiguration rec { - system = "x86_64-linux"; - homeDirectory = "/home/stuebinm"; - username = "stuebinm"; - configuration.imports = [ ./home/home.nix ]; - stateVersion = "21.03"; - extraSpecialArgs = { inherit inputs system; }; - }; + homeConfigurations = + let home = root: inputs.home-manager.lib.homeManagerConfiguration rec { + system = "x86_64-linux"; + homeDirectory = "/home/stuebinm"; + username = "stuebinm"; + configuration.imports = [ root ]; + stateVersion = "21.03"; + extraSpecialArgs = { inherit inputs system; }; + }; + in { + stuebinm = home ./home/home.nix; + stuebinm-minimal = home ./home/home-minimal.nix; + }; home = self.homeConfigurations.stuebinm.activationPackage; + home-minimal = self.homeConfigurations.stuebinm-minimal.activationPackage; }; } |