summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2023-11-30 22:21:22 +0100
committerstuebinm2023-11-30 22:21:22 +0100
commitd62e8cb43dd012187f4cdba5b106ce53016355da (patch)
tree5a02da21a667c187b34a11d8a395dfaa62996ac9 /flake.nix
parent5a60b2cc554cae28bd85f22dfd6b90f1c67f45ba (diff)
jump to nixos 23.11
Diffstat (limited to '')
-rw-r--r--flake.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 4ea0bcd..d6d6c18 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,10 +5,10 @@
'';
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.11";
nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
- home-manager.url = "github:nix-community/home-manager/release-23.05";
+ home-manager.url = "github:nix-community/home-manager/release-23.11";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
deploy-rs.url = "git+https://stuebinm.eu/git/forks/deploy-rs?ref=nom-flag";
deploy-rs.inputs.nixpkgs.follows = "nixpkgs";
@@ -16,12 +16,12 @@
"gitlab:simple-nixos-mailserver/nixos-mailserver/master";
simple-nixos-mailserver.inputs.nixpkgs.follows = "nixpkgs-unstable";
simple-nixos-mailserver.inputs.nixpkgs-23_05.follows = "nixpkgs";
+ simple-nixos-mailserver.inputs.nixpkgs-23_11.follows = "nixpkgs";
rust-overlay.url = "github:oxalica/rust-overlay";
rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
sops-nix.url = "github:Mic92/sops-nix";
sops-nix.inputs.nixpkgs.follows = "nixpkgs-unstable";
sops-nix.inputs.nixpkgs-stable.follows = "nixpkgs";
- nix-gleam.url = "github:arnarg/nix-gleam";
uplcg.url = "git+https://stuebinm.eu/git/forks/uplcg?ref=main";
uplcg.flake = false;
@@ -56,7 +56,6 @@
system = "x86_64-linux";
overlays = [
inputs.rust-overlay.overlays.default
- inputs.nix-gleam.overlays.default
self.overlays.default
];
};