summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2024-03-04 18:56:23 +0100
committerstuebinm2024-03-04 18:56:23 +0100
commit911e1fd4986c0556321457a5606f0e747ef556c6 (patch)
treeb141211dffec9b166416abc9ef92cac4f46d038e /flake.nix
parent0b7bf6205fa36e48c597bce55a65820d81cbeaec (diff)
import custom modules by default
which has the nice side-effect that they now show up on my `man configuration.nix'. (also I don't have to manually import things anymore)
Diffstat (limited to '')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index be32a3e..371d0ea 100644
--- a/flake.nix
+++ b/flake.nix
@@ -66,6 +66,7 @@
inputs.nixpkgs.lib.nixosSystem rec {
system = "x86_64-linux";
modules = [ config ] ++ imports;
+ extraModules = builtins.attrValues self.nixosModules;
pkgs = nixpkgs;
specialArgs = {
@@ -147,7 +148,7 @@
};
nixosModules = {
- glitchtip = import ./modules/glitchtip.nix;
+ # glitchtip = import ./modules/glitchtip.nix;
bookwyrm = import ./modules/bookwyrm.nix;
mollysocket = import ./modules/mollysocket.nix;
};