summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2022-12-05 16:37:27 +0100
committerstuebinm2022-12-05 16:37:27 +0100
commit8a10ea437cf74619865e0966f8be8f16e6cba938 (patch)
tree3f6d07986d3eb2963114739ccfab6ad0756fa443 /flake.nix
parent64546ed6399d49ff125ee667b9632825eb3ccba5 (diff)
update to nixos22.11
Diffstat (limited to '')
-rw-r--r--flake.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index 6a6c21f..6595b93 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,10 +3,10 @@
description = "testing nix flakes for server deployment";
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/release-22.05";
+ nixpkgs.url = "github:NixOS/nixpkgs/release-22.11";
nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
- home-manager.url = "github:nix-community/home-manager/release-22.05";
+ home-manager.url = "github:nix-community/home-manager/release-22.11";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
peerix.url = "github:cid-chan/peerix";
peerix.inputs.nixpkgs.follows = "nixpkgs";
@@ -87,12 +87,12 @@
homeConfigurations =
let home = root: inputs.home-manager.lib.homeManagerConfiguration rec {
- system = "x86_64-linux";
- homeDirectory = "/home/stuebinm";
- username = "stuebinm";
- configuration.imports = [ root ];
- stateVersion = "21.03";
- extraSpecialArgs = { inherit inputs system; };
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ modules = [ root ];
+ extraSpecialArgs = {
+ inherit inputs;
+ system = "x86_64-linux";
+ };
};
in {
stuebinm = home ./home/home.nix;