summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2023-06-30 23:39:18 +0200
committerstuebinm2023-06-30 23:39:18 +0200
commit34d980586399831d300d3aad031c555966f486af (patch)
treeaab431448d32f7d30e8e7f771b8d20561ccebf03 /flake.nix
parentd7576dbe98d128316058256424f3fc566d07ad67 (diff)
update inputs
Diffstat (limited to '')
-rw-r--r--flake.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 4da00c9..c96d5aa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,17 +1,23 @@
{
- description = "testing nix flakes for server deployment";
+ description = ''
+ stuebinm's flake stuff. re-use of packages defined here is free,
+ but perhaps don't depend on anything actually working or being maintained
+ '';
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/release-23.05";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05";
nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
nixpkgs-oldstable.url = "github:NixOS/nixpkgs/release-22.11";
- home-manager.url = "github:nix-community/home-manager/master";
+ home-manager.url = "github:nix-community/home-manager/release-23.05";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
deploy-rs.url = "github:serokell/deploy-rs";
deploy-rs.inputs.nixpkgs.follows = "nixpkgs";
simple-nixos-mailserver.url =
"gitlab:simple-nixos-mailserver/nixos-mailserver/master";
+ simple-nixos-mailserver.inputs.nixpkgs.follows = "nixpkgs-unstable";
+ simple-nixos-mailserver.inputs.nixpkgs-23_05.follows = "nixpkgs";
+ simple-nixos-mailserver.inputs.nixpkgs-22_11.follows = "nixpkgs-oldstable";
rust-overlay.url = "github:oxalica/rust-overlay";
rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
sops-nix.url = "github:Mic92/sops-nix";
@@ -40,7 +46,7 @@
bahnhof-name.url = "git+https://stuebinm.eu/git/bahnhof.name";
bahnhof-name.flake = false;
- gtfsBooks.url = "git+https://stuebinm.eu/git/gtfs-books?ref=main";
+ gtfsBooks.url = "git+https://stuebinm.eu/git/forks/gtfs-books?ref=main";
gtfsBooks.flake = false;
walint.url = "git+https://stuebinm.eu/git/walint?ref=playground";
walint.flake = false;
@@ -132,7 +138,7 @@
packages.x86_64-linux = {
inherit (nixpkgs)
galmon-core galmon-full glitchtip typst almanac
- kijetesantakaluotokieni showrt isabelle-utils isabat emacs29
+ kijetesantakaluotokieni showrt isabelle-utils isabat
travelynx crs-tracker crs-php bahnhof-name;
};