summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorstuebinm2023-03-22 21:36:28 +0100
committerstuebinm2023-03-22 21:36:28 +0100
commit212823586cedd0d5d9fea03941785f37a01a6cfe (patch)
tree7166e413b7ed1d9ca2563dd994cac9f8c028382e /flake.nix
parent4f387146f58fee9fd7aafabdb378019ea1786bd8 (diff)
get rid of crane & naersk
the only thing this makes more complicated is typst; most of the other benefits I don't use in any case.
Diffstat (limited to '')
-rw-r--r--flake.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index 8aaa8ef..dd490c5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,15 +8,10 @@
home-manager.url = "github:nix-community/home-manager/release-22.11";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
- naersk.url = "github:nix-community/naersk";
- naersk.inputs.nixpkgs.follows = "nixpkgs";
deploy-rs.url = "github:serokell/deploy-rs";
deploy-rs.inputs.nixpkgs.follows = "nixpkgs";
simple-nixos-mailserver.url = "gitlab:simple-nixos-mailserver/nixos-mailserver/master";
emacs-overlay.url = "gitlab:nix-community/emacs-overlay?rev=d938b780a3d8072aeac0178c46121060079ff217";
-
- crane.url = "github:ipetkov/crane";
- crane.inputs.nixpkgs.follows = "nixpkgs";
rust-overlay.url = "github:oxalica/rust-overlay";
rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
@@ -51,7 +46,6 @@
system = "x86_64-linux";
overlays = [
inputs.rust-overlay.overlays.default
- inputs.crane.overlays.default
self.overlays.default
];
};
@@ -61,7 +55,10 @@
modules = [ config ] ++ imports;
pkgs = nixpkgs;
- specialArgs = { inherit inputs system; };
+ specialArgs = {
+ inherit inputs system;
+ craneLib = inputs.crane.lib.${system};
+ };
};
mkServer = mkConfig [ ./common/headless.nix ];
mkDesktop = mkConfig [ ./common/desktop.nix ];
@@ -119,7 +116,9 @@
overlays.default = final: prev:
import ./pkgs/overlay.nix { inherit inputs; } final prev;
packages.x86_64-linux = {
- inherit (nixpkgs) galmon-core galmon-full glitchtip typst;
+ inherit (nixpkgs) galmon-core galmon-full glitchtip typst
+ almanac kijetesantakaluotokieni showrt isabelle-utils isabat
+ emacs29;
};
};
}