summaryrefslogtreecommitdiff
path: root/chaski/services/walint.nix
diff options
context:
space:
mode:
authorstuebinm2022-02-12 20:52:57 +0100
committerstuebinm2022-02-12 21:36:34 +0100
commite8b22eac84cd09af01c888421122656eb2384d27 (patch)
tree35a98a079f35031c06c261865dc37df8944b343d /chaski/services/walint.nix
parent4ab8d379def4a123fd4864206d50442197ee2e80 (diff)
chaski: add walint test server
Diffstat (limited to '')
-rw-r--r--chaski/services/walint.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/chaski/services/walint.nix b/chaski/services/walint.nix
new file mode 100644
index 0000000..0b17e22
--- /dev/null
+++ b/chaski/services/walint.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, inputs, ... }:
+
+{
+ systemd.services.walint = {
+ enable = true;
+ description = "test instance for walint & divoc";
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig.Type = "simple";
+ path = [ pkgs.git ];
+ script = ''
+ cd ${(import inputs.walint).walint-server}
+ ./bin/walint-server
+ '';
+ };
+
+ services.nginx.virtualHosts."walint.stuebinm.eu" = {
+ locations."/".proxyPass = "http://localhost:8080";
+ enableACME = true;
+ forceSSL = true;
+ };
+
+}