summaryrefslogtreecommitdiff
path: root/chaski/services/uplcg.nix
diff options
context:
space:
mode:
authorstuebinm2022-01-18 09:43:24 +0100
committerstuebinm2022-01-20 13:19:44 +0100
commit0bcabe1c4b1dd74af233674dfa6c6ec3011ce2c0 (patch)
tree5c58943f99245ff7f745f50b46c34ae288c3e503 /chaski/services/uplcg.nix
parentdb83a406bc6e63289e47ff5d2228c08430832655 (diff)
restructuring directories
Diffstat (limited to 'chaski/services/uplcg.nix')
-rw-r--r--chaski/services/uplcg.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/chaski/services/uplcg.nix b/chaski/services/uplcg.nix
new file mode 100644
index 0000000..5605046
--- /dev/null
+++ b/chaski/services/uplcg.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, inputs, ... }:
+
+{
+ imports = [
+ "${inputs.uplcg.outPath}/module.nix"
+ ];
+
+ services.uplcg = {
+ enable = true;
+ port = 9080;
+ domain = "0.0.0.0";
+ };
+
+ services.nginx.enable = true;
+ services.nginx.virtualHosts."cards.stuebinm.eu" = {
+ locations."/" = {
+ proxyPass = "http://localhost:9080";
+ proxyWebsockets = true;
+ };
+ enableACME = true;
+ forceSSL = true;
+ };
+}