summaryrefslogtreecommitdiff
path: root/chaski/services/bahnhof-name.nix
diff options
context:
space:
mode:
authorstuebinm2023-04-26 01:45:29 +0200
committerstuebinm2023-04-26 01:45:29 +0200
commit6b1290d8092ab097cefcfceef0a7755ed1197b8c (patch)
treec53da8bc6f72b755c8336982786016ca69970afc /chaski/services/bahnhof-name.nix
parentf1146ab5a3b3a4c0680234ba42c37dbf93f8f51c (diff)
bahnhof.name
in gleam, because why not? (tbf i will probably eventually rewrite this in a more sensible language; I haven't even found any reason to use any of the OTP features for this 🙈)
Diffstat (limited to '')
-rw-r--r--chaski/services/bahnhof-name.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/chaski/services/bahnhof-name.nix b/chaski/services/bahnhof-name.nix
new file mode 100644
index 0000000..e0e2988
--- /dev/null
+++ b/chaski/services/bahnhof-name.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+{
+ systemd.services.bahnhof-name = {
+ enable = true;
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig.Type = "simple";
+ path = [ pkgs.bahnhof-name ];
+ script = ''
+ bahnhofname
+ '';
+ };
+
+ services.nginx.virtualHosts."bahnhof.name" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/".proxyPass = "http://localhost:2345";
+ };
+}