aboutsummaryrefslogtreecommitdiff
path: root/stdlib/source/test/lux/control/parser (follow)
Commit message (Collapse)AuthorAgeFilesLines
...
* Some bug fixes.Eduardo Julian2021-08-186-12/+12
|
* Made extension-definition macros specify their bindings the same way as syntax:.Eduardo Julian2021-08-161-4/+4
|
* Moved documentation-generation machinery to its own module.Eduardo Julian2021-08-142-7/+7
|
* Made program: specify its bindings the same way as syntax:.Eduardo Julian2021-08-131-3/+3
|
* Improved binding syntax for "syntax:".Eduardo Julian2021-08-123-6/+6
|
* Relocated maybe and lazy from data to control.Eduardo Julian2021-08-1111-343/+344
|
* Improved single-line comment syntax (from "##" to "...").Eduardo Julian2021-08-092-4/+4
|
* No more #export magic syntax.Eduardo Julian2021-08-0811-96/+96
|
* Made the be/de macros for (co)monadic expression extensible.Eduardo Julian2021-08-074-20/+20
|
* Fixed a bug in the new compiler which allowed the same module to be imported ↵Eduardo Julian2021-08-021-2/+2
| | | | more than once.
* Even more renamings.Eduardo Julian2021-08-012-45/+45
|
* More renamings.Eduardo Julian2021-07-302-3/+3
|
* Switched from the "from to" convention to the "minimum additional" convention.Eduardo Julian2021-07-292-7/+7
|
* Re-named wrap => in && unwrap => out.Eduardo Julian2021-07-277-48/+48
|
* Re-named Promise to Async.Eduardo Julian2021-07-262-4/+4
|
* Better syntax for "library/lux.^multi".Eduardo Julian2021-07-259-107/+107
|
* Fixed some inconsistent naming.Eduardo Julian2021-07-161-2/+2
|
* Normalized the hierarchy of the standard library modules.Eduardo Julian2021-07-1411-264/+275
|
* Improved the XML parsing library.Eduardo Julian2021-07-131-56/+22
|
* Better syntax for parallel-hierarchy imports.Eduardo Julian2021-07-1211-22/+22
|
* "signature:" -> "interface:" & "structure:" -> "implementation:"Eduardo Julian2021-06-301-1/+1
| | | "signature" & "structure" feel like very ML-specific terminology and might not be easy on programmers unfamiliar with it.
* Re-factored the UTF8 codec into its own module.Eduardo Julian2021-05-311-10/+11
|
* Removed the (ultimately redundant) on_stop function for actors.Eduardo Julian2021-01-131-20/+20
|
* Raise error when trying to use deprecated fields/method/classes in JVM.Eduardo Julian2021-01-121-14/+14
|
* Unified repository abstraction for Aedifex.Eduardo Julian2020-12-291-1/+2
|
* Moved "lux/data/number" to "lux/math/number".Eduardo Julian2020-12-2911-51/+51
|
* Replaced kebab-case with snake_case for naming convention.Eduardo Julian2020-12-258-449/+450
|
* Refactored "export" common syntax.Eduardo Julian2020-12-232-15/+84
|
* Properly naming unicode Block type.Eduardo Julian2020-12-221-29/+31
|
* More optimizations to the Lux syntax parser.Eduardo Julian2020-12-171-1/+2
|
* Compiling "lux syntax char case!" with TABLESWITCH instead of LOOKUPSWITCH.Eduardo Julian2020-12-151-15/+16
|
* Removed several unnecessary imports.Eduardo Julian2020-12-121-2/+1
|
* Improved parsing speed for Lux code.Eduardo Julian2020-12-111-8/+8
|
* Re-named "with-cover" to "for".Eduardo Julian2020-12-1011-21/+60
|
* Re-named "::" and ":::" macros to "\" and "\\", to be consistent with the ↵Eduardo Julian2020-12-029-139/+139
| | | | convention that only macros that deal with types may start with a colon.
* Re-named lux/data/format/context to lux/control/parser/environment.Eduardo Julian2020-11-271-0/+52
|
* Allow name formatting for JVM imports, similar to Lux module imports.Eduardo Julian2020-11-269-98/+122
|
* Made the syntax of ^template more consistent.Eduardo Julian2020-11-171-46/+46
|
* Added CoMonad for CoFree.Eduardo Julian2020-11-021-1/+1
|
* Allow defining anonymous actors.Eduardo Julian2020-11-023-25/+25
|
* Improved the design of actors.Eduardo Julian2020-11-016-125/+125
|
* Re-named the directory for my bookmarks to better reflect what they are.Eduardo Julian2020-10-311-16/+16
|
* Some small refactoring.Eduardo Julian2020-10-251-3/+12
|
* Changed type-parameters for Mixin types.Eduardo Julian2020-10-241-1/+1
|
* Re-named some list functions.Eduardo Julian2020-10-241-2/+2
|
* Re-named "search" to "one" and "search-all" to "all".Eduardo Julian2020-10-241-4/+4
|
* Mandatory long names for JVM imports, instead of having "long" be optional ↵Eduardo Julian2020-10-091-2/+6
| | | | and short be default.
* Also using BIPUSH and SIPUSH during JVM generation.Eduardo Julian2020-10-091-66/+82
|
* Re-named "Cursor" type to "Location".Eduardo Julian2020-10-071-7/+7
|
* Gave Aedifex support for multiple profiles.Eduardo Julian2020-10-031-3/+3
|