Commit message (Collapse) | Author | Files | Lines | ||
---|---|---|---|---|---|
2021-07-14 | Normalized the hierarchy of the standard library modules. | Eduardo Julian | 1 | -104/+0 | |
2021-06-30 | "signature:" -> "interface:" & "structure:" -> "implementation:" | Eduardo Julian | 1 | -3/+3 | |
"signature" & "structure" feel like very ML-specific terminology and might not be easy on programmers unfamiliar with it. | |||||
2021-01-12 | Compiler now shows suggestions when encountering unknown definitions. | Eduardo Julian | 1 | -8/+9 | |
2020-12-29 | Moved "lux/data/number" to "lux/math/number". | Eduardo Julian | 1 | -3/+4 | |
2020-12-25 | Replaced kebab-case with snake_case for naming convention. | Eduardo Julian | 1 | -8/+8 | |
2020-12-02 | Replaced "contains?" function with "key?" function. | Eduardo Julian | 1 | -2/+2 | |
2020-12-02 | Re-named "::" and ":::" macros to "\" and "\\", to be consistent with the ↵ | Eduardo Julian | 1 | -1/+1 | |
convention that only macros that deal with types may start with a colon. | |||||
2020-11-28 | Re-named "_.claim" to "_.cover'". | Eduardo Julian | 1 | -4/+4 | |
2020-11-27 | Re-named lux/data/format/context to lux/control/parser/environment. | Eduardo Julian | 1 | -2/+4 | |
2020-11-05 | Lightweight machinery for agent-oriented programming. | Eduardo Julian | 1 | -0/+4 | |
2020-10-25 | Some small refactoring. | Eduardo Julian | 1 | -3/+2 | |
2020-06-29 | Added the missing cache invalidation to the new compiler. | Eduardo Julian | 1 | -2/+6 | |
2019-07-26 | No more "n/"-prefixed functions. | Eduardo Julian | 1 | -2/+4 | |
2019-04-06 | Created the "lux/abstract" branch and moved some modules into it. | Eduardo Julian | 1 | -1/+1 | |
2019-03-24 | Ported tests for collection-related modules. | Eduardo Julian | 1 | -62/+63 | |
2019-03-15 | Changed the convention for the structure opening separator from "/" to ";", ↵ | Eduardo Julian | 1 | -4/+4 | |
to avoid confusion since "/" is used for relative module paths. | |||||
2019-02-11 | Added the special # syntax for referring to the module's alias when opening ↵ | Eduardo Julian | 1 | -1/+1 | |
structures. | |||||
2019-02-04 | Changed the naming style for structures. | Eduardo Julian | 1 | -10/+10 | |
2018-07-28 | Removed temporary "|" prefix on Nat. | Eduardo Julian | 1 | -2/+2 | |
2018-07-28 | Temporary commit to get rid of "+" signs for Nat. | Eduardo Julian | 1 | -2/+2 | |
2018-07-20 | "^open" and "open:" now use aliases instead of prefixes, the same way as ↵ | Eduardo Julian | 1 | -1/+1 | |
module aliases. | |||||
2018-07-20 | No longer giving default aliases to un-prefixed imports. | Eduardo Julian | 1 | -3/+4 | |
2018-07-18 | WIP: Fix new-luxc's JVM back-end. | Eduardo Julian | 1 | -1/+6 | |
2018-07-13 | Re-named "Bool" type to "Bit". | Eduardo Julian | 1 | -4/+4 | |
2018-07-11 | - Improvements to import syntax [part 2]. | Eduardo Julian | 1 | -6/+9 | |
2018-07-11 | - Improvements to import syntax [part 1]. | Eduardo Julian | 1 | -1/+1 | |
2018-07-10 | - Improvements to import syntax [part 0]. | Eduardo Julian | 1 | -3/+3 | |
2018-07-10 | - Re-named path "lux/data/coll/*" to "lux/data/collection/*". | Eduardo Julian | 1 | -2/+2 | |
2018-07-10 | - Re-organized dictionary & set modules a bit. | Eduardo Julian | 1 | -1/+1 | |
2018-07-10 | - Re-named "Dict" type to "Dictionary". | Eduardo Julian | 1 | -2/+2 | |
2018-07-10 | - Re-implemented sets using abstract types to make it impossible to use ↵ | Eduardo Julian | 1 | -61/+66 | |
dictionary functions on them. | |||||
2018-07-10 | - Re-named "struct:" to "structure:". | Eduardo Julian | 1 | -2/+2 | |
2018-07-05 | - Re-named "equality" to "equivalence". | Eduardo Julian | 1 | -4/+4 | |
2018-05-13 | - Re-named ".../eq" modules to ".../equality". | Eduardo Julian | 1 | -1/+1 | |
- Other minor improvements. | |||||
2018-05-01 | - Re-named "lux/data/coll/dict/*" to "lux/data/coll/dictionary/*". | Eduardo Julian | 1 | -1/+1 | |
2018-05-01 | - Re-organized dict modules. | Eduardo Julian | 1 | -6/+6 | |
2018-05-01 | - Re-organized set modules. | Eduardo Julian | 1 | -0/+0 | |
2018-04-05 | - Improved the syntax for the "lux.function" macro. | Eduardo Julian | 1 | -1/+1 | |
2017-11-29 | - Changed the identifier separator, from the semi-colon (;) to the ↵ | Eduardo Julian | 1 | -13/+13 | |
period/dot (.). | |||||
2017-11-27 | - Changed the prefixes of numeric functions. | Eduardo Julian | 1 | -2/+2 | |
2017-09-19 | - Some refactoring. | Eduardo Julian | 1 | -4/+1 | |
- Moved "assume" and "default" to lux/data/maybe. | |||||
2017-07-15 | - Can now generate Eq instances for #rec-style recursive types. | Eduardo Julian | 1 | -1/+1 | |
- Minor refactorings. | |||||
2017-04-10 | - Renamed "lambda" to "function". | Eduardo Julian | 1 | -1/+1 | |
2017-04-03 | - Renamed lux/codata/* to lux/function/* and moved the ↵ | Eduardo Julian | 1 | -2/+1 | |
lux/codata/coll/stream to lux/data/coll/stream. | |||||
2017-01-26 | - Changed the license from MPL 2.0 to MIT. | Eduardo Julian | 1 | -5/+0 | |
2017-01-25 | - Moved the lux/data/struct/* modules to lux/data/coll/*. | Eduardo Julian | 1 | -2/+2 | |
- Did the same for the lux/codata/struct/* modules. - Moved lux/codata/io to lux/io. - Moved lux/control/effect to lux/effect. - Renamed "sample" functions to "this" functions. - Renamed "at" functions to "nth" functions. | |||||
2017-01-25 | - Renamed lux/data/struct/tree to lux/data/struct/tree/rose. | Eduardo Julian | 1 | -2/+2 | |
- Moved lux/data/struct/zipper to lux/data/struct/tree/zipper. - Moved lux/regex to lux/lexer/regex. - Changed the suffix of annotation tags, from M to A. - Renamed Frac(tional) numbers to Deg(rees). | |||||
2016-12-22 | - Fixed a bug in the way hierarchy->base demotion worked for Dict nodes. | Eduardo Julian | 1 | -9/+9 | |
- Fixed a bug in a test for lux/data/struct/list. | |||||
2016-12-02 | - Changed the names of math op functions to make them more consistent and ↵ | Eduardo Julian | 1 | -2/+2 | |
similar. | |||||
2016-12-01 | - Collected the Lux compiler's repo, the Standard Library's, the Leiningen ↵ | Eduardo Julian | 1 | -0/+85 | |
plugin's and the Emacs mode's into a big monorepo, to keep development unified. |