summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..bcb9f47
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,10 @@
+let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs {};
+in
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ binutils cmake gcc gnumake openssl pkgconfig rustup
+ niv
+ ];
+}