summaryrefslogtreecommitdiff
path: root/dhall/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'dhall/Cargo.toml')
-rw-r--r--dhall/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/dhall/Cargo.toml b/dhall/Cargo.toml
index 6c2c630..72fc13c 100644
--- a/dhall/Cargo.toml
+++ b/dhall/Cargo.toml
@@ -11,6 +11,9 @@ edition = "2018"
build = "build.rs"
include = ["src/**/*", "README.md", "build.rs"]
+[features]
+default = [ "reqwest" ]
+
[[test]]
name = "spec"
harness = false
@@ -33,7 +36,7 @@ url = "2.1"
# Reqwest needs proper async support to work on wasm. So no remote imports on
# wasm for now.
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-reqwest = { version = "0.10", features = ["blocking"] }
+reqwest = { version = "0.10", features = ["blocking"], optional = true }
[dev-dependencies]
anyhow = "1.0.28"