summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorNadrieril2020-05-31 16:38:43 +0100
committerNadrieril2020-05-31 16:38:43 +0100
commit1d40832097eb9095bb0dea2e1c1524bb42a8f48c (patch)
tree0234f8b7ae882ca54a12aee4c582a98a110a1a86 /shell.nix
parentda9480ad558f68d764ad61934d4385c055eda8d9 (diff)
nix: add dhall to environment
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index bcb9f47..fd71b9b 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,20 @@
let
sources = import ./nix/sources.nix;
pkgs = import sources.nixpkgs {};
+
+ dhall = pkgs.stdenv.mkDerivation rec {
+ name = "dhall-${version}";
+ version = sources.dhall.version;
+ src = sources.dhall;
+ installPhase = ''
+ mkdir -p $out/bin
+ cp $src/* $out/bin/
+ '';
+ };
in
pkgs.mkShell {
buildInputs = with pkgs; [
binutils cmake gcc gnumake openssl pkgconfig rustup
- niv
+ niv dhall
];
}