summaryrefslogtreecommitdiff
path: root/pest_consume_macros/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2019-09-09 22:42:46 +0200
committerNadrieril2019-09-09 22:42:46 +0200
commitaccaf45aa77099654f94319ed1fb12855dd568b4 (patch)
treea56ca7ee9fc2b7a5dc7bb7fb5451f8b0255129c3 /pest_consume_macros/Cargo.toml
parent595a52018e31126ecbf1be49794750f1a59a66b1 (diff)
Move pest_consume macros into their own crate
Diffstat (limited to 'pest_consume_macros/Cargo.toml')
-rw-r--r--pest_consume_macros/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pest_consume_macros/Cargo.toml b/pest_consume_macros/Cargo.toml
new file mode 100644
index 0000000..dd65d95
--- /dev/null
+++ b/pest_consume_macros/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "pest_consume_macros"
+version = "0.1.0" # remember to update html_root_url
+authors = ["Nadrieril <nadrieril@users.noreply.github.com>"]
+license = "MIT OR Apache-2.0"
+edition = "2018"
+description = "Macros for pest_consume"
+readme = "README.md"
+repository = "https://github.com/Nadrieril/dhall-rust"
+
+[lib]
+proc-macro = true
+doctest = false
+
+[dependencies]
+quote = "1.0.2"
+proc-macro2 = "1.0.2"
+syn = { version = "1.0.5", features = ["full", "extra-traits"] }