summaryrefslogtreecommitdiff
path: root/dhall_generator/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2019-03-06 14:55:01 +0100
committerNadrieril2019-03-06 14:55:01 +0100
commit45992d093b950170fc30e63d2c7d7a2767e9b9e8 (patch)
tree68bde8c8fe1ee6b4e577278a783e3f3b603b7e7f /dhall_generator/Cargo.toml
parent8f944ae4622102ad66eff19434725087239c1950 (diff)
Add proc_macro the generated dhall expressions
Diffstat (limited to '')
-rw-r--r--dhall_generator/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/dhall_generator/Cargo.toml b/dhall_generator/Cargo.toml
new file mode 100644
index 0000000..ada6707
--- /dev/null
+++ b/dhall_generator/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "dhall_generator"
+version = "0.1.0"
+authors = ["Nadrieril <nadrieril@users.noreply.github.com>"]
+edition = "2018"
+
+[lib]
+proc-macro = true
+doctest = false
+
+[dependencies]
+itertools = "0.8.0"
+quote = "0.6.11"
+proc-macro2 = "0.4.27"
+dhall_core = { path = "../dhall_core" }