summaryrefslogtreecommitdiff
path: root/dhall_core/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2019-03-06 12:19:26 +0100
committerNadrieril2019-03-06 12:19:26 +0100
commit564a5f37b106c69d8ebe9aec2f665f5222b3dfda (patch)
tree21779d5ea3bc5daaec7fa214402868cde101cfce /dhall_core/Cargo.toml
parent5b32c5bdea80a0bdf19240f3cc2b8e2ae251d51a (diff)
Split-off core into its own crate
Diffstat (limited to 'dhall_core/Cargo.toml')
-rw-r--r--dhall_core/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/dhall_core/Cargo.toml b/dhall_core/Cargo.toml
new file mode 100644
index 0000000..943e300
--- /dev/null
+++ b/dhall_core/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "dhall_core"
+version = "0.1.0"
+authors = ["NanoTech <nanotech@nanotechcorp.net>", "Nadrieril <nadrieril@users.noreply.github.com>"]
+edition = "2018"
+build = "build.rs"
+
+[build-dependencies]
+lalrpop = "0.16.3"
+
+[dependencies]
+bytecount = "0.5.1"
+itertools = "0.8.0"
+lalrpop-util = "0.16.3"
+nom = "3.0.0"
+term-painter = "0.2.3"
+pest = { git = "https://github.com/pest-parser/pest" }
+dhall_parser = { path = "../dhall_parser" }