summaryrefslogtreecommitdiff
path: root/dhall/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril Feneanar2019-12-22 00:48:35 +0000
committerGitHub2019-12-22 00:48:35 +0000
commit06e75c919d999c310f8ca1c151c6a5ad6918ca08 (patch)
tree849a54821e08c78cbff4965e1a268e050466fa6c /dhall/Cargo.toml
parentce74f996808ae84b4967040f3441e1bbba31f506 (diff)
parent139daf4da23c87366d920cea2775afe11cce7be7 (diff)
Merge pull request #122 from Nadrieril/publish
Publish to crates.io
Diffstat (limited to 'dhall/Cargo.toml')
-rw-r--r--dhall/Cargo.toml12
1 files changed, 8 insertions, 4 deletions
diff --git a/dhall/Cargo.toml b/dhall/Cargo.toml
index a93153d..34cf444 100644
--- a/dhall/Cargo.toml
+++ b/dhall/Cargo.toml
@@ -1,8 +1,11 @@
[package]
name = "dhall"
-version = "0.1.0"
+version = "0.1.1" # remember to update html_root_url
authors = ["NanoTech <nanotech@nanotechcorp.net>", "Nadrieril <nadrieril@users.noreply.github.com>"]
license = "BSD-2-Clause"
+description = "Implementation of the Dhall configuration language"
+readme = "README.md"
+repository = "https://github.com/Nadrieril/dhall-rust"
edition = "2018"
build = "build.rs"
@@ -12,9 +15,8 @@ hex = "0.3.2"
lazy_static = "1.4.0"
percent-encoding = "2.1.0"
pest = "2.1"
-# pest_consume = { path = "../../pest_consume/pest_consume" }
pest_consume = "1.0"
-serde = { version = "1.0" }
+serde = "1.0"
serde_cbor = "0.9.0"
smallvec = "1.0.0"
take_mut = "0.2.2"
@@ -24,6 +26,8 @@ pretty_assertions = "0.6.1"
[build-dependencies]
walkdir = "2"
-abnf_to_pest = { version = "0.1.1", path = "../abnf_to_pest" }
+abnf_to_pest = { version = "0.1.2", path = "../abnf_to_pest" }
+pest_generator = "2.1"
+quote = "1.0"