summaryrefslogtreecommitdiff
path: root/dhall/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2020-04-12 20:19:57 +0100
committerNadrieril2020-06-24 22:13:53 +0100
commitc8b9d7e9dbbc8c110d5cf519513294582758ccad (patch)
tree13615a946a7199de7e81d5e5dc78ec5152cdf903 /dhall/Cargo.toml
parent3d9c0b12c6b34185e556071ee16401691bfd8e49 (diff)
test: write custom test harness for tests
Diffstat (limited to 'dhall/Cargo.toml')
-rw-r--r--dhall/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/dhall/Cargo.toml b/dhall/Cargo.toml
index 9a30d24..ecb68eb 100644
--- a/dhall/Cargo.toml
+++ b/dhall/Cargo.toml
@@ -11,6 +11,10 @@ edition = "2018"
build = "build.rs"
include = ["src/**/*", "README.md", "build.rs"]
+[[test]]
+name = "spec"
+harness = false
+
[dependencies]
annotate-snippets = "0.7.0"
hex = "0.4.2"
@@ -31,9 +35,12 @@ url = "2.1"
reqwest = { version = "0.10", features = ["blocking"] }
[dev-dependencies]
+# Latest master allows tests to be run in parallel.
+libtest-mimic = { version = "0.2.0", git = "https://github.com/LukasKalbertodt/libtest-mimic" }
pretty_assertions = "0.6.1"
-version-sync = "0.9"
rand = "0.7"
+version-sync = "0.9"
+walkdir = "2"
[build-dependencies]
walkdir = "2"