summaryrefslogtreecommitdiff
path: root/dhall/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2020-05-29 22:22:30 +0100
committerNadrieril2020-05-30 13:56:22 +0100
commit4aab03c67869ff4ecc473794f62e35e4565a01d6 (patch)
treedfc09be677e226be03ef992d05d42b4d3a043751 /dhall/Cargo.toml
parentaaba9f7a1a6119443aa6a569e451e0e549e5bb37 (diff)
Make reqwest build on wasm
Diffstat (limited to 'dhall/Cargo.toml')
-rw-r--r--dhall/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/dhall/Cargo.toml b/dhall/Cargo.toml
index 376506f..adf92d6 100644
--- a/dhall/Cargo.toml
+++ b/dhall/Cargo.toml
@@ -19,13 +19,20 @@ once_cell = "1.3.1"
percent-encoding = "2.1.0"
pest = "2.1"
pest_consume = "1.0"
-reqwest = { version = "0.10", features = ["blocking"] }
serde = "1.0"
serde_cbor = "0.9.0"
sha2 = "0.8.1"
smallvec = "1.0.0"
url = "2.1"
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+reqwest = { version = "0.10", features = ["blocking"] }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+# Disable native tls because hyper doesn't build on wasm
+reqwest = { version = "0.10", default-features = false }
+blocking = "0.4.3"
+
[dev-dependencies]
pretty_assertions = "0.6.1"
version-sync = "0.8"