summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorNadrieril2019-03-01 17:28:19 +0100
committerNadrieril2019-03-01 17:28:19 +0100
commite5d9aee00b0c775df1d8e2d8819aeb80dffa73c2 (patch)
treee763a24a0d635048232e72e167ca37eafec69369 /Cargo.toml
parent8a2b7536902831079eddd7b00291b718f5dd7186 (diff)
Split abnf_to_pest and dhall into their own crates
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 5 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9775e6a..9aff88d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,20 +1,6 @@
-[package]
-name = "dhall"
-version = "0.1.0"
-authors = ["NanoTech <nanotech@nanotechcorp.net>"]
-edition = "2018"
-build = "build.rs"
+[workspace]
-[build-dependencies]
-lalrpop = "0.16.3"
-abnf = { git = "https://github.com/Nadrieril/abnf" }
-itertools = "0.8.0"
-pretty = "0.5.2"
-
-[dependencies]
-bytecount = "0.5.1"
-lalrpop-util = "0.16.3"
-nom = "3.0.0"
-term-painter = "0.2.3"
-pest = { git = "https://github.com/pest-parser/pest" }
-pest_derive = "2.0"
+members = [
+ "dhall",
+ "abnf_to_pest"
+]