aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/tests/common.nix')
-rw-r--r--nix/tests/common.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nix/tests/common.nix b/nix/tests/common.nix
new file mode 100644
index 0000000..37abb5d
--- /dev/null
+++ b/nix/tests/common.nix
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: 2024 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+
+{inputs, pkgs, ...}: {
+ nix = {
+ registry.nixpkgs.flake = inputs.nixpkgs;
+ extraOptions = ''
+ experimental-features = nix-command flakes
+ '';
+ settings = {
+ trusted-users = [ "root" "@wheel" ];
+ substituters = pkgs.lib.mkForce [];
+ };
+ };
+
+ virtualisation.graphics = false;
+ virtualisation.memorySize = 1536;
+ boot.loader.grub.enable = false;
+ documentation.enable = false;
+}