aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index edfb6bd..66b2e76 100644
--- a/flake.nix
+++ b/flake.nix
@@ -118,7 +118,7 @@
deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) {
deploy-schema = deploy: final.runCommand "jsonschema-deploy-system" { } ''
- ${final.python3.pkgs.jsonschema}/bin/jsonschema -i ${final.writeText "deploy.json" (builtins.toJSON deploy)} ${./interface.json} && touch $out
+ ${final.check-jsonschema}/bin/check-jsonschema --schemafile ${./interface.json} ${final.writeText "deploy.json" (builtins.toJSON deploy)} && touch $out
'';
deploy-activate = deploy: