aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 5d9427f..9c912e9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -56,6 +56,10 @@
];
};
+ nixosActivate = base: setActivate base "$PROFILE/bin/switch-to-configuration switch";
+
+ noopActivate = base: setActivate base ":";
+
deployChecks = deploy: builtins.mapAttrs (_: check: check deploy) {
schema = deploy: pkgs.runCommandNoCC "jsonschema-deploy-system" { } ''
${pkgs.python3.pkgs.jsonschema}/bin/jsonschema -i ${pkgs.writeText "deploy.json" (builtins.toJSON deploy)} ${./interface.json} && touch $out