aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 11 insertions, 10 deletions
diff --git a/flake.nix b/flake.nix
index 402d63f..884bbf3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,17 +34,18 @@
program = "${self.defaultPackage."${system}"}/bin/deploy";
};
- devShell = let
- inherit (self.packages.${system}) deploy-rs;
- in
- pkgs.mkShell {
- inherit (deploy-rs)
- nativeBuildInputs
- builtDependencies;
+ devShell =
+ let
+ inherit (self.packages.${system}) deploy-rs;
+ in
+ pkgs.mkShell {
+ inherit (deploy-rs)
+ nativeBuildInputs
+ builtDependencies;
- buildInputs = deploy-rs.buildInputs
- ++ [ pkgs.nixUnstable ];
- };
+ buildInputs = deploy-rs.buildInputs
+ ++ [ pkgs.nixUnstable ];
+ };
lib = rec {
setActivate = base: activate: pkgs.buildEnv {