aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 2e775ca..73c5f68 100644
--- a/flake.nix
+++ b/flake.nix
@@ -69,6 +69,15 @@
executable = true;
destination = "/deploy-rs-activate";
})
+ (pkgs.writeTextFile {
+ name = base.name + "-activate-rs";
+ text = ''
+ #!${pkgs.runtimeShell}
+ exec ${self.defaultPackage."${system}"}/bin/activate "$@"
+ '';
+ executable = true;
+ destination = "/activate-rs";
+ })
];
};