aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4513495..41035d6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -80,7 +80,12 @@
];
};
- nixos = base: custom base.config.system.build.toplevel "$PROFILE/bin/switch-to-configuration switch";
+ nixos = base: custom base.config.system.build.toplevel ''
+ $PROFILE/bin/switch-to-configuration switch
+
+ # https://github.com/serokell/deploy-rs/issues/31
+ sed -i '/^default /d' /boot/loader/loader.conf
+ '';
noop = base: custom base ":";
};