aboutsummaryrefslogtreecommitdiff
path: root/examples/system/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'examples/system/flake.nix')
-rw-r--r--examples/system/flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/system/flake.nix b/examples/system/flake.nix
index 021f9db..bcc841c 100644
--- a/examples/system/flake.nix
+++ b/examples/system/flake.nix
@@ -30,12 +30,12 @@
system = {
sshUser = "admin";
path =
- deploy-rs.lib.x86_64-linux.setActivate self.nixosConfigurations.example-nixos-system.config.system.build.toplevel "./bin/switch-to-configuration switch";
+ deploy-rs.lib.x86_64-linux.activate.nixos self.nixosConfigurations.example-nixos-system;
user = "root";
};
hello = {
sshUser = "hello";
- path = deploy-rs.lib.x86_64-linux.setActivate self.defaultPackage.x86_64-linux "./bin/activate";
+ path = deploy-rs.lib.x86_64-linux.activate.custom self.defaultPackage.x86_64-linux "./bin/activate";
user = "hello";
};
};