aboutsummaryrefslogtreecommitdiff
path: root/examples/simple/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--examples/simple/flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/simple/flake.nix b/examples/simple/flake.nix
new file mode 100644
index 0000000..e5003c7
--- /dev/null
+++ b/examples/simple/flake.nix
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: 2020 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+
+{
+ description = "Deploy GNU hello to localhost";
+
+ inputs.deploy-rs.url = "github:serokell/deploy-rs";
+
+ outputs = { self, nixpkgs, deploy-rs }: {
+ deploy.nodes.example = {
+ hostname = "localhost";
+ profiles.hello = {
+ user = "balsoft";
+ path = deploy-rs.lib.x86_64-linux.setActivate nixpkgs.legacyPackages.x86_64-linux.hello "./bin/hello";
+ };
+ };
+
+ checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib;
+ };
+}