aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorChristian Höppner2020-11-14 20:37:51 +0000
committernotgne22020-11-14 14:12:29 -0700
commitf32a6f17f6b1fb4bf9c3a9857e459177081dbb56 (patch)
treeb3032c1b29a00e76b7c5c56b358d9c52e13b8fdf /shell.nix
parentcd751f1e95c9ac5e73cf5e6b0423d05ec9adcc7f (diff)
[OPS-1085] Add CI
Diffstat (limited to '')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9eb132a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+(import
+ (
+ let
+ lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+ in
+ fetchTarball {
+ url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+ sha256 = lock.nodes.flake-compat.locked.narHash;
+ }
+ )
+ {
+ src = ./.;
+ }).shellNix