aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/server.nix
diff options
context:
space:
mode:
authorSergey Gulin2024-03-27 12:22:02 +0300
committerSergey Gulin2024-03-29 20:25:47 +0300
commita92835264100583903dc408abe43d461ff7d4dca (patch)
treef22e488e7d057772809a9936ad124915ff968b6f /nix/tests/server.nix
parent0a0187794ac7f7a1e62cda3dabf8dc041f868790 (diff)
[OPS-1384] Introduce NixOS VM tests
Problem: Currently, the only way to test deploy-rs deployments is to actually do a deployment to an existing NixOS instance (either in VM, or a real machine) manually. This is a bit inconvenient and one can forget to test changes when developing/reviewing deploy-rs changes. Solution: Add NixOS VM tests.
Diffstat (limited to 'nix/tests/server.nix')
-rw-r--r--nix/tests/server.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/tests/server.nix b/nix/tests/server.nix
new file mode 100644
index 0000000..a8bbda6
--- /dev/null
+++ b/nix/tests/server.nix
@@ -0,0 +1,23 @@
+# SPDX-FileCopyrightText: 2024 Serokell <https://serokell.io/>
+#
+# SPDX-License-Identifier: MPL-2.0
+{ pkgs, ... }:
+{
+ nix.settings.trusted-users = [ "deploy" ];
+ users = let
+ inherit (import "${pkgs.path}/nixos/tests/ssh-keys.nix" pkgs) snakeOilPublicKey;
+ in {
+ mutableUsers = false;
+ users = {
+ deploy = {
+ password = "";
+ isNormalUser = true;
+ createHome = true;
+ openssh.authorizedKeys.keys = [ snakeOilPublicKey ];
+ };
+ root.openssh.authorizedKeys.keys = [ snakeOilPublicKey ];
+ };
+ };
+ services.openssh.enable = true;
+ virtualisation.writableStore = true;
+}