aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/default.nix
diff options
context:
space:
mode:
authorRoman Melnikov2024-06-10 13:48:08 +0200
committerGitHub2024-06-10 13:48:08 +0200
commit9c3147639c233f80d333fe81f463b0a87fc49764 (patch)
tree4abe0d3155be7425c463a51658182242fe2d4c70 /nix/tests/default.nix
parent5b5ebfa4978a1173593bdeaa64952073ce6a373c (diff)
parent20261c6428220b0a849e9745d682711144907b49 (diff)
Merge pull request #277 from Anillc/patch-1
allow --ssh-opts starts with hyphen
Diffstat (limited to 'nix/tests/default.nix')
-rw-r--r--nix/tests/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nix/tests/default.nix b/nix/tests/default.nix
index b38e99d..7fe8628 100644
--- a/nix/tests/default.nix
+++ b/nix/tests/default.nix
@@ -131,4 +131,9 @@ in {
user = "deploy";
deployArgs = "-s .#profile -- --offline";
};
+ hyphen-ssh-opts-regression = mkTest {
+ name = "profile";
+ user = "deploy";
+ deployArgs = "-s .#profile --ssh-opts '-p 22 -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null' -- --offline";
+ };
}