aboutsummaryrefslogtreecommitdiff
path: root/nix/tests/common.nix
diff options
context:
space:
mode:
authorRoman Melnikov2024-06-12 14:07:33 +0200
committerGitHub2024-06-12 14:07:33 +0200
commit3867348fa92bc892eba5d9ddb2d7a97b9e127a8a (patch)
tree1c2cf8365dcabb72eb306e0e8577f2772197157b /nix/tests/common.nix
parent254e9d150aa273591aee1433112a8781fd4ffd71 (diff)
parentd3b11225fcb129ccb5e07b716b7484a93e68771d (diff)
Merge pull request #272 from stuebinm/fix-nonflake-build
fix nix-build invocation in non-flake builds
Diffstat (limited to 'nix/tests/common.nix')
-rw-r--r--nix/tests/common.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nix/tests/common.nix b/nix/tests/common.nix
index 37abb5d..9e5f363 100644
--- a/nix/tests/common.nix
+++ b/nix/tests/common.nix
@@ -2,11 +2,12 @@
#
# SPDX-License-Identifier: MPL-2.0
-{inputs, pkgs, ...}: {
+{inputs, pkgs, flakes, ...}: {
nix = {
registry.nixpkgs.flake = inputs.nixpkgs;
+ nixPath = [ "nixpkgs=${inputs.nixpkgs}" ];
extraOptions = ''
- experimental-features = nix-command flakes
+ experimental-features = ${if flakes then "nix-command flakes" else "nix-command"}
'';
settings = {
trusted-users = [ "root" "@wheel" ];